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1 Introduction 

VeriFinger 6.2/MegaMatcher 3.1 Algorithm Demo application is designed with aim to demonstrate the advanced capabilities
of Neurotechnology fingerprint recognition engine. The program is a Windows 2000/XP/Vista/7, Linux OS 2.6 (or newer) or
Mac OS X application controlled via a pull-down menu system.

The application has four operation modes:

1. Fingerprint enrollment. Software processes the fingerprint image, extracts features and writes them to the database.

2. Enrollment with features generalization. This mode generates the generalized fingerprint features collection up-to ten 
fingerprints of the same finger. Each fingerprint image is processed and features are extracted. Then multiple collections 
of features are analyzed and combined into one generalized features collection, which is written to the database. The 
fingerprint recognition quality considerably increases if fingerprints were enrolled using this mode. Features generalization 
can use from 3 to 10 collections.

3. Fingerprint verification mode. This mode performs 1:1 fingerprints matching.

4. Fingerprint identification mode. This mode performs 1:N fingerprint matching. Using this mode fast or full fingerprints 
matching can be performed.

Operation mode can be changed using "Mode" menu. 

Neurotechnology  fingerprint  recognition  algorithm  demo  shows  how  to  considerably  decrease  the  recognition  time  by
stopping the fingerprint  matching process when positive matching result  is found (successful  identification).  To turn off  this
feature go to "Options" dialog (Tools»Options…) and select "Stop on first result".

In the application the database entries are pre-sorted using certain global  features.  Thereafter,  matching is  performed first
within small part of the database entries having most similar global features to those of the test fingerprint. If matching within
this  group yields  no positive  result,  then the next  group with  most  similar  global  features is  examined and so on,  until  the
matching is successful or the end of the database is reached (this behavior can be changed by modifying value of "Match at
most  XXX% of  database"  in  "Options"  dialog).  In  most  cases  there  is  fairly  good  chance  that  correct  match  will  be  found
already  in  the  first  group.  Consequently,  the  number  of  comparisons  required  to  achieve  positive  matching  becomes
drastically  decreased,  and  correspondingly,  the  effective  matching  speed  increases.  This  feature  can  be  used  with  fast
identification mode (in this case G is used).

1.1 Fingerprint Scanners 
The following fingerprint scanners are supported: 

Fingerprint 
scanner 
model

Description Requirements

ARH AFS 510 AFS510  live  scanner  is  a  professional,
compact  10  fingerprint  scanning  device  for
acquisition  of  single  finger  flats,  rolls  and  four
finger slaps.

Supported OS: Microsoft Windows (32 bit)

DLLs:

• FPSmm\FPSmmArhFpr.dll
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U.are.U 2000S The  U.are.U  2000  fingerprint  scanner  is  a
self-contained  sensor  for  capturing  a
fingerprint  and  communicating  the  digital
image to PfC via USB interface. The on-board
electronics  control  image  capture,
self-calibration,  and  the  Plug-n-Play  USB
interface.

Supported  OS:  Microsoft  Windows  (32  bit
and 64 bit).

Drivers:

• \install\Fingerprint Scanners\UareU\

DLLs:

• FPSmm\FPSmmUareU.dll

DigitalPersona
U.are.U
4000S  /
U.are.U 4000B

The  U.are.U  4000  fingerprint  sensor  is
designed to work with PC via USB port. It has
slim  design  and  small  form  factor.  The
on-board  electronics  control  image  capture,
latent fingerprint rejection, self-calibration, and
the Plug-n-Play USB interface.

Supported  OS:  Microsoft  Windows  (32  bit
and 64 bit).

Drivers:

• \install\Fingerprint Scanners\UareU\

DLLs:

• FPSmm\FPSmmUareU.dll

DigitalPersona
U.are.U
Fingerpint
Keyboard

This  is  104-key  Windows  compatible
keyboard  with  a  built-in  U.are.U  4000
fingerprint  sensor.  The  keyboard  requires  two
connections:  PS/2  connection  for  keyboard
functioning and USB for fingerprint scanner.

Supported  OS:  Microsoft  Windows  (32  bit
and 64 bit).

DigitalPersona
U.are.U  4000
Fingerpint
Module

Description:  The  U.are.U  4000  Module  is  a
small  fingerprint  scanner  designed  for
integration  into  OEM  equipment  where
fingerprint authentication is needed.

Supported  OS:  Microsoft  Windows  (32  bit
and 64 bit).

DigitalPersona
U.are.U 4500

DigitalPersona  U.are.U  4500  is  an  optical
USB  2.0  fingerprint  scanner.  The  scanner  is
able to reject latent and spoof fingerprints.

Supported  OS:  Microsoft  Windows  (32  bit
and 64 bit).

Drivers:

• \install\Fingerprint Scanners\UareU\

DLLs:

• FPSmm\FPSmmUareU.dll

Cross  Match
Verifier  300
Classic

This  scanner  is  intended for  professional  use.
It operates via USB port.

Supported OS: Microsoft Windows (32bit)

Drivers:  Can  be  downloaded  from  CrossMatch  website
(section  "USB  SDK  for  Verifier  and  MV5
Scanners/Readers")
http://www.crossmatch.com/software.html#_USB_SDK_for

DLLs:

• FPSmm\FPSmmCrossMatch.dll

Cross  Match
Verifier 300 LC

Verifier  300  LC  (Lexan  Case)  features  light
weight (less than 0.5 kg).  It  operates via USB
port.

Supported OS: Microsoft Windows (32bit).

Drivers:  Can  be  downloaded  from  CrossMatch  website
(section  "USB  SDK  for  Verifier  and  MV5
Scanners/Readers")
http://www.crossmatch.com/software.html#_USB_SDK_for

DLLs:

• FPSmm\FPSmmCrossMatch.dll

Cross  Match
Verifier  300
LC 2.0

An  improved  version  of  Verifier  300  LC.
Features  faster  frame  rate  and  an  I/R  filter  to
improve ambient light rejection.

Supported OS: Microsoft Windows (32bit).

Drivers:  Can  be  downloaded  from  CrossMatch  website
(section  "USB  SDK  for  Verifier  and  MV5
Scanners/Readers")
http://www.crossmatch.com/software.html#_USB_SDK_for

DLLs:

• FPSmm\FPSmmCrossMatch.dll

1.1 Fingerprint Scanners VeriFinger 6.2/MegaMatcher 3.1

Copyright © 1998-2010 Neurotechnology. All rights reserved.

2

1

http://www.crossmatch.com/software.html#_USB_SDK_for
http://www.crossmatch.com/software.html#_USB_SDK_for
http://www.crossmatch.com/software.html#_USB_SDK_for
http://www.neurotechnology.com


Cross  Match
Verifier 310

This  scanner  allows  to  scan  two  flat
fingerprints  simultaneously  or  one  rolled
fingerprint.

Supported OS: Microsoft Windows (32bit).

Drivers:  Can  be  downloaded  from  CrossMatch  website
(section  "USB  SDK  for  Verifier  and  MV5
Scanners/Readers")
http://www.crossmatch.com/software.html#_USB_SDK_for

DLLs:

• FPSmm\FPSmmCrossMatch.dll

Futronic
FS80,
Futronic FS82

Supported OS:  Microsoft Windows (32bit and
64bit), Linux (32 bit).

Remarks:  Configuration  futronic.cfg  file
with parameter LFD = false will turn of the life
fingerprint  detection.  For  BioLink  U-Match
MatchBook  v.3.5  scanner  file  with  parameter
LFD = false should be created all the time.

Drivers:

• \install\Fingerprint Scanners\Futronic\

DLLs:

• FPSmm\FPSmmFutronic.dll

• FPSmm\ftrScanAPI.dll 

Futronic
eFAM (FS84)

Futronic  FS84  is  an  ethernet  Fingerprint
Authentication  Module  (eFAM)  suitable  for
embedded,  regular  or  remote  applications.
The  module  can  be  controlled  via  standard
Ethernet  interface  by  any  host  system  or  via
serial interface.

1  output  channel  (for  external  relay  control)
and  2  input  channels  (for  door  sensor  and
switch)  are  available  for  external  device
control.  Electric  lock  or  other  electric  device
can be activated by eFAM using these output
control signals.

Supported OS:  Microsoft Windows (32bit and
64bit), Linux (32 bit and 64 bit), Mac OS X.

Remarks:
FPSmmFutronicEthernetFam.ini  file  is
intended  for  scanner  configuration.  Scanner
IP  address  and  port  should  be  placed  in  file.
Examples:
192.168.2.255 5001

or for few scanners
192.168.2.253 5001

192.168.2.254 5001

192.168.2.255 5005

Drivers:

• \install\Fingerprint 
Scanners\FutronicEthernetFam\

DLLs:

• FPSmm\FPSmmFutronicEthernetFam.dll

Futronic FS88 The  scanner  is  an  enhanced  version  of
Futronic  FS80  scanner.  This  scanner  was
certified  by  FBI  to  be  compliant  with
PIV-071006  Image  Quality  Specification  for
Singer  Finger  Reader.  The  FS88  scanner
includes  an  electronic  circuit  for  live  finger
detection.

Supported OS:  Microsoft Windows (32bit and
64bit), Linux (32 bit).

Remarks:  Configuration  futronic.cfg  file
with parameter LFD = false will turn of the life
fingerprint  detection.  For  BioLink  U-Match
MatchBook  v.3.5  scanner  file  with  parameter
LFD = false should be created all the time.

Drivers:

• \install\Fingerprint Scanners\Futronic\

DLLs:

• FPSmm\FPSmmFutronic.dll

• FPSmm\ftrScanAPI.dll 
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Futronic FS50 This  scanner  can  capture  single  finger,  dual
finger  and  roll  finger  image.  The  scanner  can
also  handle  bad  fingers  such  as  dry,  wet,
blurred and scarred without any problem.

Supported OS:  Microsoft Windows (32bit and
64bit)

Remarks:  Configuration  futronic.cfg  file
with parameter LFD = false will turn of the life
fingerprint detection.

Drivers:

• \install\Fingerprint Scanners\Futronic\

DLLs:

• FPSmm\FPSmmFutronic.dll

• FPSmm\ftrScanAPI.dll 

Futronic FS60 FS60 is professional fingerprint scanner which
can capture high quality 4 fingerprints image.

Supported OS: Microsoft Windows (32 bits)

Drivers:

• \install\Fingerprint 
Scanners\FutronicMF\

DLLs:

• FPSmm\FPSmmFutronicMF.dll

• FPSmm\ftrMFAPI.dll

NITGEN
eNBioScan-F

The  scanner  meets  FBI's  Integrated  AFIS
Image Quality Specifications (IQS) and is able
to scan wet fingers.

Supported OS:  Microsoft Windows (32bit and
64bit), Linux (32 bit).

Remarks:  FPSmmNitgen.dll  from
Additional  folder  should  be  copied  to  FPSmm
folder in order to use this scanner driver.

Drivers:

• \install\Fingerprint Scanners\Nitgen\

DLLs:

• FPSmm\Additional\FPSmmNitgen.dll

• FPSmm\NBioBSP.dll 

NITGEN
Fingkey
Hamster

Supported OS:  Microsoft Windows (32bit and
64bit).

Remarks:  FPSmmNitgen.dll  from
Additional  folder  should  be  copied  to  FPSmm
folder in order to use this scanner driver.

Drivers:

• \install\Fingerprint Scanners\Nitgen\

DLLs:

• FPSmm\Additional\FPSmmNitgen.dll

• FPSmm\NBioBSP.dll 

NITGEN
Fingkey
Hamster II

Supported OS:  Microsoft Windows (32bit and
64bit).

Remarks:  FPSmmNitgen.dll  from
Additional  folder  should  be  copied  to  FPSmm
folder in order to use this scanner driver.

Drivers:

• \install\Fingerprint Scanners\Nitgen\

DLLs:

• FPSmm\Additional\FPSmmNitgen.dll

• FPSmm\NBioBSP.dll 

SecuGen
Hamster  III
scanner

Supported  OS:  Microsoft  Windows  (32bit),
Linux (32 bit).

Remarks:  FPSmmSecugenHFDU03.dll  from
Additional  folder  should  be  copied  to  FPSmm
folder in order to use this scanner driver.

Drivers:

• \install\Fingerprint 
Scanners\SecuGenHFDU03\

DLLs:

• FPSmm\Additional\FPSmmSecugenHFDU03.dll

SecuGen
Hamster  Plus
scanner

Supported OS: Microsoft Windows (32bit).

Remarks:  FPSmmSecugenHFDU02.dll  from
Additional  folder  should  be  copied  to  FPSmm
folder in order to use this scanner driver.

Drivers:

• \install\Fingerprint 
Scanners\SecuGenHFDU02\

DLLs:

• fpsmm\Additional\FPSmmSecugenHFDU02.dll
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SecuGen
Hamster  IV
scanner

Supported OS: Microsoft Windows (32bit).

Remarks:  FPSmmSecugenHFDU04.dll  from
Additional  folder  should  be  copied  to  FPSmm
folder in order to use this scanner driver.

Drivers:

• \install\Fingerprint 
Scanners\SecuGenHFDU04\

DLLs:

• fpsmm\Additional\FPSmmSecugenHFDU04.dll

SecuGen
iD-USB SC

Supported OS: Microsoft Windows (32bit).

Remarks:  FPSmmSecugenHFDU02.dll  from
Additional  folder  should  be  copied  to  FPSmm
folder in order to use this scanner driver.

Drivers:

• \install\Fingerprint 
Scanners\SecuGenHFDU02\

DLLs:

• fpsmm\Additional\FPSmmSecugenHFDU02.dll

SecuGen
iD-USB SC/PV

Supported OS: Microsoft Windows (32bit).

Remarks:  FPSmmSecugenHFDU04.dll  from
Additional  folder  should  be  copied  to  FPSmm
folder in order to use this scanner driver.

Drivers:

• \install\Fingerprint 
Scanners\SecuGenHFDU04\

DLLs:

• fpsmm\Additional\FPSmmSecugenHFDU04.dll

Dermalog ZF1 The scanner is able to detect fake fingers and
to scan both dry and wet fingerprints.

Supported OS: Microsoft Windows (32bit).

Drivers:

• \install\Fingerprint 
Scanners\DermalogZF1\

DLLs:

• FPSmm\Additional\FPSmmDermalogZF1.dll

• FPSmm\DermalogVC3.dll

• FPSmm\DermalogCalibrateSDK.dll

• FPSmm\DermalogLoggingFacility.dll

• FPSmm\DermalogPLS1.dll

• FPSmm\ZFScanAPI.dll

BioLink
U-Match
MatchBook
v.3.5

Supported  OS:  Microsoft  Windows  (32bit),
Linux (32 bit).

Drivers:

• \install\Fingerprint Scanners\Futronic\

DLLs:

• FPSmm\FPSmmFutronic.dll

• FPSmm\ftrScanAPI.dll

Testech Bio-i Supported OS: Microsoft Windows (32bit). Drivers:

• \install\Fingerprint Scanners\Testech\

DLLs:

• FPSmm\FPSmmCyte.dll

• FPSmm\BioNetCapture.dll
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Startek
FM200
scanner

Supported  OS:  Microsoft  Windows  (32bit),
Linux (32bit and 64bit), Mac OS X.

Drivers:

• \install\Fingerprint Scanners\Startek\

DLLs:

• FPSmm\FPSmmFM200.dll

• FPSmm\fm200api.dll

• FPSmm\FingerPrinterDll.dll

• FPSmm\fm200drv.dll

Tacoma
CMOS
Scanner

Supported  OS:  Microsoft  Windows  (32bit),
Linux (32bit and 64bit), Mac OS X.

Drivers:

• \install\Fingerprint Scanners\Tacoma\

DLLs:

• FPSmm\FPSmmTacoma.dll

• FPSmm\SmzCmos1.dll

• FPSmm\SMZ_API.dll

Fujitsu
MBF200

Supported  OS:  Microsoft  Windows  (32bit),
Linux (32bit and 64bit), Mac OS X.

Drivers:

• \install\Fingerprint Scanners\Fujitsu\

DLLs:

• FPSmm\FPSmmFujitsu.dll

• FPSmm\libusb0.dll

Identix  DFR
2080

Supported OS: Microsoft Windows (32bit).

Remarks:  Drivers  for  this  scanner  are  not
included  into  the  VeriFinger  6.2/MegaMatcher
3.1 Algorithm Demo.

Remarks:  FPSmmIdentixR.dll  from
Additional  folder  should  be  copied  to  FPSmm
folder in order to use this scanner driver.

DLLs:

• FPSmm\Additional\FPSmmIdentixR.dll

• FPSmm\Itf32_2080U2.dll 

Identix  DFR
2090

This  scanner  is  intended for  professional  use.
The  image  output  is  in  USB  digital  and
RS-170 analog video formats.

Supported OS: Microsoft Windows (32bit).

Remarks:  Drivers  for  this  scanner  are  not
included  into  the  VeriFinger  6.2/MegaMatcher
3.1 Algorithm Demo.

DLLs:

• FPSmm\Additional\FPSmmIdentixR.dll

• FPSmm\Itf32_2080U2.dll

Identix  DFR
2100

Supported OS: Microsoft Windows (32bit). DLLs:

• FPSmm\Additional\FPSmmIdentixR.dll

• FPSmm\Itf32_2080U2.dll

TST
Biometrics
BiRD 3

TST  Biometrics  offers  its  touchless  sensor
technology that allows to scan a finger without
physical contact with a fingerprint sensor. The
BiRD  3  sensor  is  available  as  desktop
scanner,  on-wall  mounted  scanner  and  as
OEM  components.  Optionally,  a  5V  AC
powered  heating  device  could  be  included  for
operating in cold environment.

Supported OS: Microsoft Windows (32bit).

Drivers can be downloaded from TST Biometrics website
http://www.tst-biometrics.com/.

DLLs:

• FPSmm\Additional\FPSmmTSTBIRD.dll

• FPSmm\TSTBasic.dll
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Digent  Izzix
FD1000

Supported OS: Microsoft Windows (32bit). Drivers:

• \install\Fingerprint Scanners\Digent\

DLLs:

• FPSmm\FPSmmDigent.dll

• FPSmm\IZZIX.dll

UPEK
TouchChip
TCRU1C

This scanner is built on the TouchChip Silicon
Fingerprint  Sensor.  It  communicates  PC  via
USB port.

Supported OS: Microsoft Windows (32bit).

Drivers:

• \install\Fingerprint Scanners\Upek\

DLLs:

• FPSmm\FPSmmUpek.dll

• FPSmm\TCI.dll

UPEK
TouchChip
TCRU2C

Supported OS: Microsoft Windows (32bit). Drivers:

• \install\Fingerprint Scanners\Upek\

DLLs:

• FPSmm\FPSmmUpek.dll

• FPSmm\TCI.dll

UPEK Eikon Supported OS: Microsoft Windows (32 bit) Drivers:

• \install\Fingerprint Scanners\Upek\

DLLs:

• FPSmm\FPSmmEikon.dll

Eikon  Touch
700,  Eikon
Touch 300

Supported OS: Microsoft Windows (32 bit) Drivers:

• \install\Fingerprint Scanners\Upek\

DLLs:

• FPSmm\iaapi.dll

• FPSmm\FPSmmUpek.dll

Green  Bit
DactyScan 26

Supported OS: Microsoft Windows (32bit).

Remarks:  Drivers  for  this  scanner  are  not
included  into  the  VeriFinger  6.2/MegaMatcher
3.1 Algorithm Demo.

DLLs:

• FPSmm\FPSmmDactyScan.dll

• FPSmm\FSM26U.dll

Hongda S680 This scanner allows to scan rolled fingerprints.
A plastic lid can be mounted on top of sensor
for more comfortable flat fingerprint scanning.

Supported OS: Microsoft Windows (32bit).

Drivers:

• \install\Fingerprint Scanners\Hongda\

DLLs:

• FPSmm\FPSmmHongda.dll

Jstac  Athena
210

Supported OS: Microsoft Windows (32bit). Drivers:

• \install\Fingerprint Scanners\Jsatck\

DLLs:

• FPSmm\FPSmmJstac.dll

• FPSmm\WIS_API.dll

• FPSmm\WisCmos2.dll
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BiometriKa  FX
2000

BiometriKa  FX  2000  desktop  fingerprint
scanner  is  intended  for  using  with  PC.
Scanner communicates PC via USB interface.
FX  2000  contains  32  bit  RISC  processor  for
encrypting fingerprint data, controlling scanner
operations and other operations.

Supported  OS:  Microsoft  Windows  (32bit),
Linux (32 bit).

Drivers:

• \install\Fingerprint 
Scanners\BiometriKa\

DLLs:

• FPSmm\FPSmmBiometrika.dll

• FPSmm\fx3.dll

• FPSmm\fx3scan.dll

BiometriKa  FX
3000

Supported  OS:  Microsoft  Windows  (32bit),
Linux (32 bit).

Drivers:

• \install\Fingerprint 
Scanners\BiometriKa\

DLLs:

• FPSmm\FPSmmBiometrika.dll

• FPSmm\fx3.dll

• FPSmm\fx3scan.dll

BiometriKa
HiScan

Supported  OS:  Microsoft  Windows  (32bit),
Linux (32 bit).

Drivers:

• \install\Fingerprint 
Scanners\BiometriKa\

DLLs:

• FPSmm\FPSmmBiometrika.dll

• FPSmm\fx3.dll

• FPSmm\fx3scan.dll

Lumidigm
Venus  Series
sensors

Supported OS:  Microsoft Windows (32bit and
64 bit), Linux (32 bit)

Remarks:  Configuration  lumidigm.cfg  file
with parameter LFD = true will turn on the life
fingerprint  detection,  parameter
LFDThreshold=7000  is  life  fingerprint
detection  threshold,  the  LFDThreshold
parameter rage is [0-4294967296).

lumidigm.cfg  file  should  be  placed  near
FPSmmLumidigm.dll  file.  Default
parameters  are  LFD  =  false  and
LFDThreshold=7000

Drivers:

• \install\Fingerprint Scanners\Lumidigm\

DLLs:

• FPSmm\LumiAPI.dll

• FPSmm\LumiCore.dll

• FPSmm\FPSmmLumidigm.dll

Lumidigm
Mercury
Series sensors

Supported  OS:  Microsoft  Windows  (32  bit
and 64 bit), Linux (32 bit)

Drivers:

• \install\Fingerprint Scanners\Lumidigm\

DLLs:

• FPSmm\LumiAPI.dll

• FPSmm\LumiCore.dll

• FPSmm\FPSmmLumidigm.dll
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Dakty
Fingerprint
NAOS-A

A fiber  optic  fingerprint  sensor  with  live  finger
detection  using  human  body  capacitance,
blood oxygen presence and pulse measuring.

Supported OS: Microsoft Windows (32bit).

Drivers:

• \install\Fingerprint Scanners\DaktyFpd\

DLLs:

• FPSmm\FPSmmDaktyScan.dll

• FPSmm\DaktyImage.dll

• FPSmm\fpd.dll

• FPSmm\fpdusb.dll

• FPSmm\Segmentation.dll

id3  Certis
Image

An  Atmel  FingerChip  based  scanner  with  a
sweeping thermal sensor.

Supported OS: Microsoft Windows (32bit).

Drivers:

• \install\Fingerprint Scanners\Certis\

DLLs:

• FPSmm\FPSmmCertis.dll

• FPSmm\CertisExports.dll

• FPSmm\Id3BiokeyDll.dll

CS-Pass  USB
Fingerprint
Sensor

The  CS-Pass  USB  Fingerprint  Sensor  is
based  on  AuthenTec  AES4000  sensor.  It  is
suitable  for  PC  and  mobile  devices,  including
battery  powered  devices.  The  sensor  can  be
customized for specific projects.

Supported  OS:  Microsoft  Windows  (32bit),
Linux (32 bit and 64 bit), Mac OS X.

EntréPad
AES2501B

Supported  OS:  Microsoft  Windows  (32bit),
Linux (32 bit).

EntréPad
AES4000

The AES4000 fingerprint sensor is suitable for
PC  and  mobile  devices.  Sensor's  small  size
and  low  power  is  ideally  suited  for  battery
powered devices.

Supported  OS:  Microsoft  Windows  (32bit),
Linux (32 bit and 64 bit), Mac OS X.

FingerLoc
AF-S2

The  AF-S2  fingerprint  sensor  is  suitable  for
the embedded devices.

Supported  OS:  Microsoft  Windows  (32bit),
Linux (32 bit and 64 bit), Mac OS X.

LTT-C500
Fingerprint
Sensor

Supported OS: Microsoft Windows (32bit). DLLs:

• FPSmm\FPSmmLighTunning.dll

• FPSmm\GetImageC500.dll

Atmel
FingerChip

Supported OS: Microsoft Windows (32bit). Drivers:

• \install\Fingerprint Scanners\AtmelFC\

DLLs:

• FPSmm\FPSmmAtmel.dll

• FPSmm\FingerChip.dll
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Zvetco  Verifi
P4000

An  USB  2.0  scanner  based  on  AES4000
capacitive sensor.

Supported  OS:  Microsoft  Windows  (32bit),
Linux (32 bit and 64 bit), Mac OS X.

Drivers:

• \install\Fingerprint Scanners\AuthenTec

DLLs:

• FPSmm\Additional\FPSmmAuthentec2501.dll

Zvetco  Verifi
P5000

A  FIPS-201  compliant  USB  2.0  fingerprint
scanner.  The  scanner  is  based  on  the  UPEK
TCR1  capacitive  sensor,  that  is  also  used  in
TCRU1C  fingerprint  scanner.  P5000  scanner
is  rugged  and  scratch  resistant.  Scanner's
sensor  has  protective  coating  that  is  able  to
withstand more than 10 million touches.

Supported OS: Microsoft Windows (32bit).

Drivers:

• \install\Fingerprint Scanners\Upek

DLLs:

• FPSmm\FPSmmUpek.dll

• FPSmm\TCI.dll

ZKSoftware
ZK6000

ZK6000  is  an  optical  USB  2.0  fingerprint
scanner.  The  scanner  is  able  to  reject  latent
and spoof fingerprints.

Supported OS: Microsoft Windows (32bit).

Drivers:

• \install\Fingerprint 
Scanners\ZKSensor6000\

DLLs:

• FPSmm\FPSmmZKSensor6000.dll

CrossMatch  L
Scan Guardian

CroosMatch  L  Scan  Guardian  is  live
ten-fingerprints scanner.

Supported OS: Microsoft Windows (32 bit)

Remarks:  Before  starting  the  scanner  its
sensor should be cleaned, otherwise it will not
be able to initialize.

For  4  fingerprints  scanning  fingerprints
segmentation module is required. This module
is included only in MegaMatcher SDK.

Drivers:

• \install\Fingerprint 
Scanners\LScanEssentials\

DLLs:

• FPSmm\FPSmmCrossMatch.dll

Suprema
BioMini

Suprema  BioMini  is  a  high  performance  USB
fingerprint scanner.

Supported  OS:  Microsoft  Windows  (32  bit)
and Linux (32 bit)

Drivers:

• \install\Fingerprint Scanners\Suprema\

DLLs:

• FPSmm\FPSmmSuprema.dll

Suprema
SFR300-S

Suprema  SFR300-S  is  a  high  performance
USB  fingerprint  scanner  for  fingerprint
authentication in desktop or network security.

Supported OS: Microsoft Windows (32 bit).

Drivers:

• \install\Fingerprint Scanners\Suprema\

DLLs:

• FPSmm\FPSmmSuprema.dll

Suprema
SFR300-R

Supported OS: Microsoft Windows (32 bit). Drivers:

• \install\Fingerprint 
Scanners\SupremaSFR300R\

DLLs:

• FPSmm\FPSmmSupremaSFR300R.dll

1.1 Fingerprint Scanners VeriFinger 6.2/MegaMatcher 3.1
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Suprema
RealScan-D

Supported OS: Microsoft Windows (32bit) Drivers:

• \install\Fingerprint Scanners\Suprema\

DLLs:

• FPSmm\FPSmmRealScan.dll

Note:  realscan.cfg  configuration  file  should  be
created in FPSmm folder.  When mode value is rolled
one  fingerprint  can  be  scanned.  When  the  value  is
flat, one, two or four fingerprints can be scanned.

Suprema
RealScan-10

Supported OS: Microsoft Windows (32bit) Drivers:

• \install\Fingerprint Scanners\Suprema\

DLLs:

• FPSmm\FPSmmRealScan.dll

Note:  realscan.cfg  configuration  file  should  be
created in FPSmm folder.  When mode value is rolled
one  fingerprint  can  be  scanned.  When  the  value  is
flat, one, two or four fingerprints can be scanned.

Suprema
SFR3000

Supported OS: Microsoft Windows (32 bit). Drivers:

• \install\Fingerprint Scanners\Suprema\

DLLs:

• FPSmm\FPSmmRealScan.dll 

Futronic FS90 Supported  OS:  Microsoft  Windows  (32bit),
Linux (32bit).

Drivers:

• \install\Fingerprint Scanners\Futronic\

DLLs:

• FPSmm\FPSmmFutronic.dll

• FPSmm\ftrScanAPI.dll 

SOP1 Supported OS: Microsoft Windows (32bit). Drivers:

• \install\Fingerprint Scanners\SOP1\

DLLs:

• FPSmm\FPSmmSOP1.dll

• FPSmm\sop1.dll

Vista MT Supported  OS:  Microsoft  Windows  (32  bit
and 64 bit)

Drivers:

• \install\Fingerprint Scanners\VistaMT\

DLL:

• FPSmm\FPSmmVistaMT.dll

• FPSmm\VciMt.dll

1.1 Fingerprint Scanners VeriFinger 6.2/MegaMatcher 3.1
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LES
Fingerprint
scanner  from
Integrated
Biometrics

Supported  OS:  Microsoft  Windows  (32  bit
and 64 bit*)

*  This  scanner  supports  only  Windows  7  and
2008 64 bits OS.

Drivers:

• \install\Fingerprint Scanners\Cyte\

DLL:

• FPSmm\FPSmmCyte.dll

• FPSmm\BioNetCapture.dll

Nitgen
Fingkey
Mouse I, II, III

Supported OS:  Microsoft Windows (32bit and
64 bit)

Remarks:  FPSmmNitgen.dll  from
Additional  folder  should  be  copied  to  FPSmm
folder in order to use this scanner driver.

Drivers:

• \install\Fingerprint Scanners\NITGEN\

DLLs:

• fpsmm\Additional\FPSmmNitgen.dll

• fpsmm\NBioBSP.dll 

1.1 Fingerprint Scanners VeriFinger 6.2/MegaMatcher 3.1
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2 Application 

VeriFinger 6.2/MegaMatcher 3.1 Algorithm Demo is menu-driven software designed with intention to give the potential user a
possibility  to  test  our  fingerprint  image  processing  and  recognition  engine  in  action.  Using  Neurotechnology  fingerprint
recognition  algorithm  demo  application  mainly  involves  running  fingerprint  enrollment,  enrollment  with  features
generalization, verification and identification procedures, described below.

2.1 Windows 
VeriFinger  6.2/MegaMatcher  3.1  Algorithm  Demo  application  in  Windows  OS  can  be  started  from
FingersAlgorithmDemo.exe.

2.1.1 Main Window 

The  main  Neurotechnology  fingerprint  recognition  algorithm  demo  window  contains  a  menu  bar  at  the  top,  and  four  child
windows. In the top left window, the original fingerprint image is displayed, in the top right window, the same image after the
image filtering/processing/feature extraction is shown with features and their directions marked in red by circles and lines. In
the  bottom-left  window,  enrollment  and  recognition  information  (enrolled/recognized  file  name,  fingerprint  processing  and
matching  times,  number  of  samples  matched,  etc.)  is  displayed.  In  the  bottom  right  window,  individual  matching  scores
between different fingerprints (in identification mode) are displayed.

The VeriFinger 6.2/MegaMatcher 3.1 Algorithm Demo application's window: 

2.1 Windows VeriFinger 6.2/MegaMatcher 3.1 Main Window
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(The right upper pane shows fingerprint image from database. The upper left pane shows extracted fingerprint features.)

2.1.2 Fingerprint Input 

Neurotechnology fingerprint recognition algorithm demo allows reading fingerprints from all supported scanners (  see page
1). Before using scanner please install scanner driver provided in demo drivers directory. Using "File->Scanners..." window
you can choose which fingerprint scanners to use:

Neurotechnology  fingerprint  recognition  algorithm  demo  software  also  allows  reading  fingerprint  images  from  image  files
(either *.bmp, *.wsq or *.tif). There is a collection of sample fingerprint images (in *.bmp format) available for download from
Neurotechnology web site (http://www.neurotechnology.com/download.html).

2.1 Windows VeriFinger 6.2/MegaMatcher 3.1 Fingerprint Input
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Fingerprint enrollment

For the fingerprint enrollment demonstration, select "Mode->Enroll" from the menu. Then, open file(s) or scan a fingerprint.
To stop long enrollment operation choose "File->Cancel".

Note: When working with big number of image files file list can be created for later use.

Fingerprint enrollment with features generalization

For the fingerprint enrollment with features generalization demonstration, select "Mode->Enroll  generalized" mode from the
menu. Generalization requires multiple images. Image count can be changed in "Tools->Options…->Number of templates".
Then open multiple files or scan multiple images.

Fingerprint Verification

Select "Mode->Verify" and open two files or scan two images.

Fingerprint Identification

For the fingerprint identification demonstration, select "Mode->Identify (fast)" or "Mode->Identify (full)" from the menu. Then
open  file(s)  or  scan  an  image  to  identify.  Use  fast  identification  when  you  want  to  achieve  the  maximum  possible
identification speed. When you need the maximum possible accuracy you should use full identification mode.

After  the  identification  demo  application  will  output  the  record  names  of  the  most  similar  fingerprint  together  with  the
similarity  criterion (to see all  matching result  deselect  "Stop on first  result"  in Options dialog (  see page 15))  and various
characteristics of the recognition process.

To stop lengthy enrollment or identification operations choose "File->Cancel".

Note: When working with big number of image files the file list can be created for later use.

2.1.3 Options Dialog 

VeriFinger  6.2/MegaMatcher  3.1  Algorithm  Demo  allows  to  change  various  parameters  of  Neurotechnology  fingers
recognition algorithm. Algorithm parameters can be changed using Options window (Tools->Options...).

2.1 Windows VeriFinger 6.2/MegaMatcher 3.1 Options Dialog
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Fingerprints enrollment options

• Search for duplicates - controls duplicate search. This options is used to protect application from enrolling duplicate 
fingerprint images. It can be chosen between fast and full duplicates search. Full duplicates search is the most accurate 
and will find all duplicate fingerprint images. But full search can be inappropriate for big databases, because duplicate 
search can affect enrolling time. It is recommended to use fast duplicate search, which is not so accurate, but the search 
speed is greater. If duplicate search during fingerprints enrolling is not necessary, it can be switched off by selecting 
Disabled option.

• Save images to database - if checked, saves enrolled fingerprint images to database. During identification or verification 
saved fingerprint image can be used for displaying matching result.

• Minimum minutia count - minimum required minutia count for fingerprint to be enrolled to database.

• Enable quality check - if checked, fingerprint quality check is performed during enrollment. If fingerprint's quality threshold 
is less than specified value, fingerprint template will not be created.

• Quality threshold - controls how strict rules are applied when determining the quality of a fingerprint for extraction.

• Mode - used to select fingerprint features extraction mode optimized for particular scanner.

• Template size - size of fingerprint image templates. Can be used Large or Small template. It is recommended to use large 
template size.

• Number of templates - number of fingerprint template required for features generalization.

• Generalization FAR - generalization false rejection rate.

• Maximal rotation - maximal fingerprint's rotation value.

• Minimum minutia count - minimum minutia count required in each fingerprint used for generalization.

2.1 Windows VeriFinger 6.2/MegaMatcher 3.1 Options Dialog
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Fingerprints matching options

• Algorithm - used for selecting Neurotechnology product to test its fingerprint matching algorithm capabilities. VeriFinger 
6.2/MegaMatcher 3.1 Algorithm Demo can be used to test MegaMatcher and VeriFinger algorithms.

• FAR - threshold that separates identical and different fingerprints. Matching threshold is linked to false acceptance rate 
(FAR, different fingerprints erroneously accepted as of the same) of matching algorithm. The higher is threshold, the 
lower is FAR and higher FRR (false rejection rate, same fingerprints erroneously accepted as different) and vice a versa.

• Maximal rotation - maximal fingerprint's rotation value.

• Matching speed - matching speed. Can be chosen Low, Medium or High speed. Default value is Low.

• Mode - used to perform matching optimized for a particular fingerprints scanner.

• Match at most - this option affects fast identification mode. It is used to define what part of existing database should be 
matched when duplicate search or identification is performed. The bigger part of database will be matched the bigger 
probability to find matching templates. Alternatively, the lower this value is, the greater matching speed is achieved. But 
the lower this value is, the bigger probability that template will no be found in database. When it is required the most 
accurate matching results it is recommended to use full identification (full identification performs matching within all 
database).

• Stop on first result - if checked, application stops matching when first result was found. Otherwise, all matching templates 
will be found (search will be perform through all database).

2.2 Linux 
VeriFinger  6.2/MegaMatcher  3.1  Algorithm Demo application  on Linux  can be started  from FingersAlgorithmDemo  file.
There are separate distribution for 32 bits and 64 bits operating system. See Windows (  see page 13) part to find out how
to use this application.

2.3 Mac OS X VeriFinger 6.2/MegaMatcher 3.1
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2.3 Mac OS X 
VeriFinger  6.2/MegaMatcher  3.1  Algorithm  Demo  application  on  Mac  OS  can  be  started  from
FingersAlgorithmDemo.app file. See Windows (  see page 13) part to find out how to use this application.

2.3 Mac OS X VeriFinger 6.2/MegaMatcher 3.1
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3 Distribution Content 

VeriFinger 6.2/MegaMatcher 3.1 Algorithm Demo distribution contains these files and folders: 

File/Folder Description

/Drivers This  folder  contains  installation  files  and  drivers  for  various  fingerprint  scanners.  The  folder
name in this directory indicates a fingerprint scanner model.

/fpsmm Files under this directory are drivers (libraries) for fingerprint scanners.

FingersAlgorithmDemo.exe Fingerprint recognition algorithm demo executable file.

3 VeriFinger 6.2/MegaMatcher 3.1
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4 Support 

If  you  encounter  problems  while  installing  or  using  Neurotechnology  Iris  Recognition  Algorithm  Demo  application,  please
contact Neurotechnology (support@neurotechnology.com) or your local distributor.

4 VeriFinger 6.2/MegaMatcher 3.1
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